Partial Support Phone System Outage
Incident Report for Admin7 Brink POS
Resolved
All phone services are showing normal functionality; this incident has been resolved.
Posted Sep 24, 2023 - 15:41 PDT
Investigating
We are currently experiencing an issue with our phone service preventing our support team from making outbound calls. This is also impacting queue callbacks on our support phone lines.

While we are working urgently to resolve this issue, please stay on the line while calling in for support or utilize the appropriate support email paths of support.brinksoftware@partech.com for direct support customers and BrinkPartnerSupport@partech.com for partner and peer-to-peer customers.

Thank you for your patience as we investigate this issue.
Posted Sep 23, 2023 - 16:40 PDT
This incident affected: Customer Support Telephone Services.